Joomla! Announcement

We are happy to announce that as of today all our major Joomla extensions Spambotcheck, Visforms and Visforms Subscription are also available for Joomla 4. This completes the migration of our software products for Joomla 4.

Instructions for the migration can be found here:

Forum

You can get answers directly from the developer in our forum. You need an active Visforms subscription or an active subscription for the Bootstrap Carousel module if you want to ask questions about the corresponding extension in our forum. Please log in with the relevant user first.

Read-only use of the forums is free for everybody.

Topic-icon form disappears

More
1 month 3 weeks ago #8173 by LilaOnlus
form disappears was created by LilaOnlus
I have upgraded the subscription and i have a big problem.
I don't find anymore form i created before upgrading. Then I created a new form but when i finished the process, i dont find the form in the list of forms that is completly empty. I repeated the process but the resoult is always the same: when the process is finished i don't find the form anymore in the list.






More
1 month 3 weeks ago #8174 by Administrator AV
Replied by Administrator AV on topic form disappears
Hi,
what is the installed Visforms Version and what is the installed Visforms Subscription Version?
Regards,
Aicha

-- Visforms Developer --
Always consult our documentations before asking a question on our forum, the answer is most probably there. :)
Bitte konsultiere immer zuerst unsere Dokumentationen bevor du eine Frage im Forum stellst, die Antwort ist bestimmt da. :)
Enjoy Joomla!

More
1 month 3 weeks ago #8175 by LilaOnlus
Replied by LilaOnlus on topic form disappears
vfbase_j3.9.0_3.0.4
vfsubscription_j3.9.0_3.5.8

More
1 month 2 weeks ago #8176 by Administrator AV
Replied by Administrator AV on topic form disappears
Hi,
thanks.
Just had to make sure, that everything is up to date.

I remember, that we had one person, using Visforms, who once had a similiar problem.
I took a deep looked into the problem then.
Here is and we found out, then.

There was an sql-Error while trying to load the form record set from the data base, due to a bad configuration of the database.
The error message was: Illegal mix of collations (utf8mb4_general_ci,IMPLICIT) and (utf8mb4_unicode_ci,IMPLICIT) for operation '='.
Usually Joomla! and Visforms themselves handle the correct database setting.
If the database driver, which is used, has UTF8MB4 support, the Joomla standard requires to change the character encoding to utf8mb4_general_ci.
Visforms installations and update implement this change with regards to all Visforms data tables, as does Joomla, with regrads to all Joomla core tables.

I guess, that not all tables in your database have the correct collations.
(In the case I mentioned, the collation of some tables had been changed, using the akeeba admin tools).

The collations of all tables have to be compatible with each other (identical).
Because of the SQL-Error the form records cannot be loaded from the database and cannot be displayed.
The forms are not gone, it is "only" a display problem.
You have to fix the problem with your database by making sure, that all tables have the same collation.

Regards,
Aicha

-- Visforms Developer --
Always consult our documentations before asking a question on our forum, the answer is most probably there. :)
Bitte konsultiere immer zuerst unsere Dokumentationen bevor du eine Frage im Forum stellst, die Antwort ist bestimmt da. :)
Enjoy Joomla!

More
1 month 2 weeks ago #8179 by Administrator AV
Replied by Administrator AV on topic form disappears
Hi,
were you able to fix the problem?
Regards,
Aicha

-- Visforms Developer --
Always consult our documentations before asking a question on our forum, the answer is most probably there. :)
Bitte konsultiere immer zuerst unsere Dokumentationen bevor du eine Frage im Forum stellst, die Antwort ist bestimmt da. :)
Enjoy Joomla!

More
1 month 2 weeks ago #8185 by LilaOnlus
Replied by LilaOnlus on topic form disappears
Today, when i reopened the extencion, all forms were listed! 
I suppose there is an hide problem in one of the table that fixes by the system when the browser's session restarts. 
Other thing: yesterday, i created lot of forms, because they desappeared and i repeat the process many time. Today I finded all those forms; more of them have the same name and alias. It's ok? (screenshot)
In order to collaction, my system uses utf8mb4_unicode_ci for all text fields.

Moderators: Administrator AVAdministrator IV